Kdenlive/Instalação

De Cartola

(Diferença entre revisões)
(2.1. Ubuntu 12.04, 12.10 e 13.04)
(2.1. Ubuntu 12.04, 12.10 e 13.04)
Linha 35: Linha 35:
e escolher os pacotes de acordo com o resultado.
e escolher os pacotes de acordo com o resultado.
 +
'''ffmpeg'''
Para alguns codecs será também necessário atualizar o ffmpeg. Recentemente ele foi substituido pelo avconv, então é necessário um processo manual para atualizar no sistema. Use o repositório https://launchpad.net/~jon-severinsson/+archive/ubuntu/ffmpeg que ainda mantém atualizações para várias versões de ubuntu.
Para alguns codecs será também necessário atualizar o ffmpeg. Recentemente ele foi substituido pelo avconv, então é necessário um processo manual para atualizar no sistema. Use o repositório https://launchpad.net/~jon-severinsson/+archive/ubuntu/ffmpeg que ainda mantém atualizações para várias versões de ubuntu.
 +
 +
Para versões mais antigas, como a minha (12.04) o mais fácil é usar os binários estáticos [http://johnvansickle.com/ffmpeg/ baixados direto do site indicado pelo ffmpeg], substituindo os executáveis do sistema por eles em /usr/bin.
== 2.2. FreeBSD ==
== 2.2. FreeBSD ==

Edição de 20h51min de 27 de março de 2015

Fotografia e Vídeo | Kdenlive

2. Instalação

Não cobrimos todos os detalhes de instalação em todas as plataformas aqui. O objetivo é alertar para alguns detalhes importantes que podem não permitir que uma instalação funcione adequadamente.

2.1. Ubuntu 12.04, 12.10 e 13.04

A instalação básica pode ser feita de maneira padrão, da forma como você preferir, seja pela Central de Programas do Ubuntu, seja pela linha de comandos. Há pacotes disponíveis. O problema é que isso não é suficiente para a funcionalidade completa da ferramenta. É preciso instalar alguns codec's que não estão nos repositórios padrão do Ubuntu para permitir salvar a saída final em mais formatos, e, por sinal, nos formatos em geral mais interessantes.

O Kdenlive usa o ffpmeg para a renderização final de seus vídeos, mas no Ubuntu a simples instalação do ffmpeg não disponibiliza todos os formatos desejados. Após a instalação padrão é necessário instalar alguns outros pacotes. Na versão 12.04 resolvi com a instalação de:

libavcodec-extra-53
libavformat-extra-53

Note que a versão (53) pode ser diferente em outras distribuições ou daqui a algum um tempo. É o caso de pesquisar o que há disponível com:

 sudo apt-cache search libav | grep extra

e escolher os pacotes de acordo com o resultado.

Outros links na internet falam da instalação dos codecs "unstripped", como os mencionados a seguir para resolver o mesmo problema:

libavcodec-unstripped-52
libavdevice-unstripped-52
libavformat-unstripped-52
libavutil-unstripped-49
libpostproc-unstripped-51
libswscale-unstripped-0

É o caso de pesquisar o que há disponível com:

 sudo apt-cache search unstripped | grep lib

e escolher os pacotes de acordo com o resultado.

ffmpeg Para alguns codecs será também necessário atualizar o ffmpeg. Recentemente ele foi substituido pelo avconv, então é necessário um processo manual para atualizar no sistema. Use o repositório https://launchpad.net/~jon-severinsson/+archive/ubuntu/ffmpeg que ainda mantém atualizações para várias versões de ubuntu.

Para versões mais antigas, como a minha (12.04) o mais fácil é usar os binários estáticos baixados direto do site indicado pelo ffmpeg, substituindo os executáveis do sistema por eles em /usr/bin.

2.2. FreeBSD

Essas instruções foram elaboradas testando a instalação num FreeBSD 9.1rc1.

  • Instale o kdenlive via pacote binário ou ports, como preferir
  • Depois da instalação o programa estará disponível em /usr/local/kde4/bin/kdenlive

A instalação padrão do kdenlive é o bastante para que o programa esteja disponível, mas faltarão alguns codecs, principalmente para renderizar o resultado final do seu vídeo. A instalação padrão do ffmpeg, principal ferramenta usada para a saída final, não coloca ele com um bom número de codecs. Um exemplo, ao clicar no formato mpeg-4 recebemos uma mensagem de erro por falta do codec de áudio lamemp3.

  • É necessário reinstalar o ffmpeg (ou fazer assim desde o início) compilando e colocando o maior número de opcionais possível.
  • Se já instalou o ffmpeg:
    • Instale o portupgrade
    • Execute-o com:
portupgrade -f ffmpeg
  • Se ele não abrir uma tela azul para a configuração do port, interrompa a instalação e dê o comando:
cd /usr/ports/multimedia/ffmpeg
make config
  • E depois dê o portupgrade mostrado acima
  • Se ainda não instalou o ffmpeg
cd /usr/ports/multimedia/ffmpeg
make install clean
  • Se ele não abrir uma tela azul para a configuração do port, interrompa a instalação e dê o comando:
make config


Quando o novo ffmpeg estiver instalado é necessário executar novamente o assistente de configuração no kdenlive, mesmo que você o feche a abra novamente, para que ele detecte nos novos codecs.

  • Va no menu "Settings" / "Executar o Assistente de Configuração"
  • Siga todos os passos até o fim

Para verificar é preciso testar se o exemplo do codec para mpeg-4 está disponível.

Atenção: se você instalou codecs após já ter configurado o kdenlive pode ter que reexecutar o assistente de configuração inicial para ativá-los. Para isso vá ao menu Settings.

2.3. Windows

Infelizmente não há uma versão do Kdenlive para MS Windows, mas é possível executá-lo através de um Live DVD (o que por enquanto não vou abordar aqui) ou virtualização. Através da instalação de uma "máquina virtual", como o Virtualbox, um programa gratuito, é possível instalar um programa dentro do Windows que se faz passar por um computador. Nele instalamos então o Linux com o Kdenlive. Na verdade não é preciso instalar o Linux se já houver uma imagem de sistema pronta com tudo instalado e configurado e por isso eu criei e disponibilizei uma imagem que possibilite isso.

Antes de seguir esse caminho, porém, verifique se sua máquina tem condições de rodar outra máquina dentro dela, pois é isso que vai acontecer no final das contas. É como se você tivesse que ter, mal comparando, um computador com o dobro da capacidade necessária para um. Recomendo um computador com algo parecido a um processador i3 (ou equivalente) com 4GB de RAM. Menos que isso pode não ser bom.

Ferramentas pessoais
Anúncio